This topic discusses importing data from another database into the current database. If you want to import text into the current database, see Text Import.

To import another database into the current one, choose File>Import>Import Database. This opens a panel that allows you to select an open database and configure how the data flows from that database into the current database. Here’s an overview of this wizard.

Let’s walk thru the process of importing text step-by-step. We’ll be importing text into this simple mailing list database, which already contains one record:

We’ll be importing this contact database. The database to be imported must already be open.

Opening the Wizard — To start, choose File>Import>Import Database to open the wizard, then select the database to be imported.

Matching the Fields — By default, Panorama will import the fields in order, 1st field into 1st field, 2nd into 2nd, 3rd into 3rd, etc. But in this case, there’s a problem —— the field order between these two databases doesn’t match.

Fortunately the field names do match, so the solution is to switch to the Append Fields by Name option.

Append vs. Replace — The Import Database wizard normally appends the data from the second database, but you can also choose to wipe out the original data and completely replace it with the data from the second database.

All Records/Selected records — The Import Database wizard normally imports all of the records in the second database, but you can choose to import only records that are currently selected. If you select this option, the wizard will show you how many records are currently selected.

Importing into the Database — The final step is to actually import the data. To do that, click on the Import button. If you have chosen the Append Fields by Name option and none of the names in the incoming database matches any of the names in the initial database, the Import button will be greyed out and you will not be able to complete the import.

If the import doesn’t turn out the way you expected, don’t worry, just choose Edit>Undo.


See Also


History

VersionStatusNotes
10.0NewNew in this version.